Importing custom Techne model for mobs

From MCreator Wiki
Jump to: navigation, search

NOTE: Techne has some bugs (for example: enderman model is buggy) and importing sometimes may not work as excepted. But it will in most cases

Contents

Instructions

You can import custom models made by techne in MCreator but you have to follow these instructions.

  • Start Techne (you can do this via MCreator in new mob screen if you already have installed it on computer)
  • Make new model: Select tab normal and enter name. Let call it TestModel1. Select model type and size and click Create
  • Design your model as you wish
  • If you add new cubes, make sure that you make them inside existing model (see picture). You can drag it on right to put it under model node. Names of elements can contain only numbers and english aplphabet chars. But the name of the element can't start with number ( 1stelement - WRONG; element1 - OK). Also make sure that each element (shape) has its own name so they don't duplicate!!!. This is example of what can be done and what not:

ex1.png

Shape3 isn't under model node and it needs to be dragged or removed

  • Click File > Export as > Texturemap
  • Edit texture file using Photoshop, Gimp 2 or other image editing software
  • Import that texture in MCreator by going in Right tools menu and clicking Add mob texture
  • Go back to Techne and click File > Export as > Java. Give the file any name you wish
  • Go in MCreator and Click New mod and select Mob as mod type and click OK
  • Select texture you edited and imported in MCreator
  • Click Import model
  • Select java file you exported in previous step
  • MCreator asks you for name. Give it the same name as you gave it in techne when you made new model. In our case TestModel1 and click OK
  • Create mob as usual

Troubleshooting

If you get recompilation errors, delete mod and open Techne file you exported. Remove these lines of code:

ModelRenderer ;
= new ModelRenderer(this, 0, 0);
.addBox(0F, 9F, 0F, 1, 1, 1);
.setRotationPoint(0F, -19F, 0F);
.setTextureSize(64, 32);
.mirror = true;
setRotation(, 0F, 0F, 0F);
.render(f5);

Save file and try importing it again in MCreator

History

Model importing was introduced with mob update. It was not working till MCreator 1.3.3 update. Now it works in mot cases.

Video tutorial

If you made a video tutorial you can send it to my mail and I will post it here

Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox
Google AdSense